dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / media-libs / faac / faac-1.29.9.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools multilib-minimal
7
8 DESCRIPTION="Free MPEG-4 audio codecs by AudioCoding.com"
9 HOMEPAGE="https://www.audiocoding.com"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1 MPEG-4"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
15
16 src_prepare() {
17         default
18         sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466984
19         eautoreconf
20 }
21
22 multilib_src_configure() {
23         ECONF_SOURCE="${S}" econf --disable-static
24
25         # do not build the frontend for non-native abis
26         if ! multilib_is_native_abi; then
27                 sed -i -e 's/frontend//' Makefile || die
28         fi
29 }
30
31 multilib_src_install_all() {
32         einstalldocs
33
34         # no static archives
35         find "${D}" -name '*.la' -delete || die
36 }