media-libs/bio2jack-0.9-r2: alpha stable
[gentoo.git] / media-libs / bio2jack / bio2jack-0.9-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools
6
7 DESCRIPTION="A library for porting blocked I/O OSS/ALSA audio applications to JACK"
8 HOMEPAGE="http://bio2jack.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/bio2jack/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
14 IUSE="static-libs"
15
16 RDEPEND="media-libs/libsamplerate
17         virtual/jack"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 S=${WORKDIR}/${PN}
22
23 src_prepare() {
24         eapply_user
25
26         # upstream does not provide a real release, it releases a tarball
27         # with a _prebuilt_ copy of bio2jack. Drop all of the built stuff
28         # and recreate autotools from scratch, then build.
29         rm -rf *.a *.o *.la *.lo .libs .deps Makefile config.{log,status} stamp-h1 stamp || die
30
31         eautoreconf
32 }
33
34 src_configure() {
35         econf \
36                 --enable-shared \
37                 $(use_enable static-libs static)
38 }
39
40 src_install() {
41         emake DESTDIR="${D}" install
42         dobin bio2jack-config
43         dodoc AUTHORS ChangeLog NEWS README
44         rm -f "${ED}"usr/lib*/lib*.la
45 }