media-libs/libebur128: version bump 1.2.4
[gentoo.git] / media-libs / aribb24 / aribb24-1.0.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Library for decoding ARIB STD-B24 subtitles"
9 HOMEPAGE="https://github.com/nkoriyama/aribb24"
10 SRC_URI="https://github.com/nkoriyama/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-3"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm arm64 ppc ppc64 x86"
15
16 RDEPEND="media-libs/libpng:0="
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig
19 "
20
21 src_prepare() {
22         default
23         eautoreconf
24 }
25
26 src_configure() {
27         econf --disable-static
28 }
29
30 src_install() {
31         default
32         find "${D}" -name '*.la' -delete || die
33 }