dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / media-gfx / xzgv / xzgv-0.9.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Fast and simple GTK+ image viewer"
8 HOMEPAGE="https://sourceforge.net/projects/xzgv"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~ppc64 x86"
14 IUSE=""
15
16 RDEPEND="x11-libs/gtk+:2"
17 DEPEND="${RDEPEND}
18         sys-apps/texinfo
19         virtual/pkgconfig"
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P/.1}-asneeded-and-cflags.patch
23 }
24
25 src_compile() {
26         emake CC="$(tc-getCC)"
27         emake -C doc CC="$(tc-getCC)"
28 }
29
30 src_install() {
31         emake PREFIX="${D}/usr" install
32         dodoc AUTHORS NEWS README TODO
33 }