Use https by default
[gentoo.git] / media-gfx / splash-themes-livecd / splash-themes-livecd-2007.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit eutils
6
7 MY_P="gentoo-livecd-${PV}"
8 MY_REV="0.9.5"
9 DESCRIPTION="Gentoo theme for gensplash consoles"
10 HOMEPAGE="https://www.gentoo.org/"
11 SRC_URI="https://dev.gentoo.org/~wolf31o2/sources/${PN}/${MY_P}-${MY_REV}.tar.bz2"
12
13 SLOT=${PV}
14 LICENSE="Artistic GPL-2 BitstreamVera"
15 KEYWORDS="amd64 ~ppc x86"
16 IUSE=""
17 RESTRICT="binchecks strip"
18
19 DEPEND=">=media-gfx/splashutils-1.4.1"
20
21 S="${WORKDIR}/${MY_P}"
22
23 pkg_setup() {
24         if ! built_with_use media-gfx/splashutils mng
25         then
26                 ewarn "MNG support is missing from splashutils.  You will not see the"
27                 ewarn "service icons as services are starting."
28         fi
29 }
30
31 src_unpack() {
32         unpack ${A}
33         cd "${S}"
34         sed -i -e 's-/sbin/functions.sh-/etc/init.d/functions.sh-' scripts/rc_init-pre
35 }
36
37 src_install() {
38         dodir /etc/splash/livecd-${PV}
39         cp -r "${S}"/* "${D}"/etc/splash/livecd-${PV}
40 }