Use https by default
[gentoo.git] / media-gfx / splash-themes-livecd / splash-themes-livecd-2007.0-r2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6
7 inherit eutils
8
9 MY_P="gentoo-livecd-${PV}"
10 MY_REV="0.9.6"
11 DESCRIPTION="Gentoo theme for gensplash consoles"
12 HOMEPAGE="https://www.gentoo.org/"
13 SRC_URI="mirror://gentoo/${PN}/${MY_P}-${MY_REV}.tar.bz2"
14
15 SLOT=${PV}
16 LICENSE="Artistic GPL-2 BitstreamVera"
17 KEYWORDS="amd64 ~ppc x86"
18 IUSE=""
19 RESTRICT="binchecks strip"
20
21 RDEPEND=">=media-gfx/splashutils-1.5.4[png]"
22 DEPEND="${RDEPEND}"
23
24 S="${WORKDIR}/${MY_P}"
25
26 pkg_setup() {
27         if ! built_with_use media-gfx/splashutils mng
28         then
29                 ewarn "MNG support is missing from splashutils.  You will not see the"
30                 ewarn "service icons as services are starting."
31         fi
32 }
33
34 src_install() {
35         dodir /etc/splash/livecd-${PV}
36         cp -r "${S}"/* "${D}"/etc/splash/livecd-${PV}
37 }