Use https by default
[gentoo.git] / media-gfx / splash-themes-gentoo / splash-themes-gentoo-20101212-r2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 DESCRIPTION="A collection of Gentoo themes for splashutils"
8 HOMEPAGE="https://dev.gentoo.org/~spock/"
9 SRC_URI="mirror://gentoo/fbsplash-theme-emergence-r2.tar.bz2
10          mirror://gentoo/fbsplash-theme-gentoo-r2.tar.bz2
11          mirror://gentoo/fbsplash-theme-emerge-world-1.0.tar.bz2
12          http://fbsplash.berlios.de/themes/repo/natural_gentoo-9.0-r2.tar.bz2"
13
14 LICENSE="freedist"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc ~x86"
17 IUSE=""
18
19 RDEPEND=">=media-gfx/splashutils-1.1.9.5[png]"
20 DEPEND="${RDEPEND}"
21
22 S="${WORKDIR}"
23 RESTRICT="binchecks strip"
24
25 src_prepare() {
26         sed -i -e 's/natural-gentoo/natural_gentoo/g' natural_gentoo/*.cfg || die 'sed failed'
27 }
28
29 src_install() {
30         # They need to be executable, bug #470100
31         insinto /etc/splash
32         doins -r *
33
34         # They need to be executable, bug #470100
35         fperms +x /etc/splash/emerge-world/scripts/svc_started-pre
36         fperms +x /etc/splash/emerge-world/scripts/svc_start-pre
37         fperms +x /etc/splash/emerge-world/scripts/svc_stopped-pre
38         fperms +x /etc/splash/emerge-world/scripts/svc_stop-pre
39 }
40
41 pkg_postinst() {
42         if [[ -z ${REPLACING_VERSIONS} ]]; then
43                 elog "The upstream tarball for the 'Natural Gentoo' theme also contains a GRUB"
44                 elog "splash image which is not installed by this ebuild.  See:"
45                 elog "  http://www.kde-look.org/content/show.php?content=49074"
46                 elog "if you are interested in this."
47         fi
48 }