b593461c8fd13cbb44e5a3c58c65e0778a7bdc12
[gentoo.git] / media-gfx / scour / scour-0.37.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
10 HOMEPAGE="https://github.com/scour-project/scour"
11 SRC_URI="https://github.com/scour-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86"
16 IUSE=""
17
18 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         dev-python/six[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}"
21
22 python_test() {
23         "${EPYTHON}" testscour.py -v || die "Tests fail with ${EPYTHON}"
24 }