6d884d56e17047412f895735087e7df5eb115f43
[gentoo.git] / media-gfx / scour / scour-0.35-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
7 inherit distutils-r1
8
9 DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
10 HOMEPAGE="http://www.codedread.com/scour/"
11 SRC_URI="https://github.com/codedread/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~hppa ~x86"
16 IUSE=""
17
18 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         dev-python/six[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}"
21
22 python_test() {
23         "${EPYTHON}" testscour.py -v || die "Tests fail with ${EPYTHON}"
24 }