*/*: Bump copyright on files touched this year
[gentoo.git] / media-gfx / pstoedit / pstoedit-3.70-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Translate PostScript and PDF graphics into other vector formats"
9 HOMEPAGE="https://sourceforge.net/projects/pstoedit/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
15 IUSE="emf imagemagick plotutils pptx static-libs"
16
17 RDEPEND="
18         >=media-libs/gd-2.0.35-r1:=
19         >=app-text/ghostscript-gpl-8.71-r1
20         emf? ( >=media-libs/libemf-1.0.3 )
21         imagemagick? ( >=media-gfx/imagemagick-6.6.1.2[cxx] )
22         plotutils? ( media-libs/plotutils )
23         pptx? ( dev-libs/libzip )
24 "
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig
27 "
28
29 PATCHES=(
30         "${FILESDIR}"/${PN}-3.60-libdl.patch
31         "${FILESDIR}"/${PN}-3.70-pkgconfig.patch
32 )
33
34 src_prepare() {
35         default
36
37         sed -i \
38                 -e '/CXXFLAGS="-g"/d' \
39                 -e 's:-pedantic::' \
40                 configure.ac || die
41
42         eautoreconf
43 }
44
45 src_configure() {
46         econf \
47                 $(use_enable static-libs static) \
48                 $(use_with emf) \
49                 $(use_with imagemagick magick) \
50                 $(use_with plotutils libplot) \
51                 $(use_with pptx) \
52                 --without-swf
53 }
54
55 src_install() {
56         default
57         doman doc/pstoedit.1
58         dodoc doc/*.txt
59         docinto html
60         dodoc doc/*.htm
61
62         find "${ED}" -name '*.la' -delete
63 }