Use https by default
[gentoo.git] / media-gfx / phototonic / phototonic-1.5.54.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit qmake-utils
7
8 DESCRIPTION="Image viewer and organizer"
9 HOMEPAGE="http://oferkv.github.io/phototonic/"
10 if [[ ${PV} = *9999* ]]; then
11         inherit git-r3
12         EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
13 else
14         SRC_URI="https://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 LICENSE="GPL-3"
19 SLOT="0"
20 IUSE="svg tiff"
21
22 RDEPEND="dev-qt/qtwidgets:5
23         dev-qt/qtgui:5
24         dev-qt/qtcore:5
25         media-gfx/exiv2:=
26         svg? ( dev-qt/qtsvg:5 )
27         tiff? ( dev-qt/qtimageformats:5 )"
28 DEPEND="${RDEPEND}"
29
30 src_configure() {
31         eqmake5
32 }
33
34 src_install() {
35         emake install INSTALL_ROOT="${D}"
36 }