dev-ruby/tins: ia64 keyworded, bug #551654
[gentoo.git] / media-gfx / jhead / jhead-2.96.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
9 HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
10 SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
11
12 LICENSE="public-domain"
13 SLOT="0"
14 KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
15 IUSE=""
16
17 src_prepare() {
18         # bug 275200 - respect flags and use mktemp instead of mkstemp
19         epatch "${FILESDIR}"/${PN}-2.90-mkstemp_respect_flags.patch
20 }
21
22 src_compile() {
23         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
24 }
25
26 src_install() {
27         dobin ${PN}
28         dodoc *.txt
29         dohtml *.html
30         doman ${PN}.1
31 }