Merge remote-tracking branch 'github/pr/760'.
[gentoo.git] / media-gfx / gnome-screenshot / gnome-screenshot-3.16.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="no"
7
8 inherit gnome2 readme.gentoo
9
10 DESCRIPTION="Screenshot utility for GNOME"
11 HOMEPAGE="https://git.gnome.org/browse/gnome-screenshot"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
17
18 # libcanberra 0.26-r2 is needed for gtk+:3 fixes
19 COMMON_DEPEND="
20         >=dev-libs/glib-2.35.1:2[dbus]
21         >=media-libs/libcanberra-0.26-r2[gtk3]
22         x11-libs/cairo
23         x11-libs/gdk-pixbuf
24         >=x11-libs/gtk+-3.0.3:3
25         x11-libs/libX11
26         x11-libs/libXext
27 "
28 RDEPEND="${COMMON_DEPEND}
29         >=gnome-base/gsettings-desktop-schemas-0.1.0
30         !<gnome-extra/gnome-utils-3.4
31 "
32 # ${PN} was part of gnome-utils before 3.4
33 DEPEND="${COMMON_DEPEND}
34         x11-proto/xextproto
35         >=dev-util/intltool-0.40
36         virtual/pkgconfig
37 "
38
39 DOC_CONTENTS="${P} saves screenshots in ~/Pictures/ and defaults to
40         non-interactive mode when launched from a terminal. If you want to choose
41         where to save the screenshot, run 'gnome-screenshot --interactive'"
42
43 src_install() {
44         gnome2_src_install
45         readme.gentoo_create_doc
46 }
47
48 pkg_postinst() {
49         gnome2_pkg_postinst
50         readme.gentoo_print_elog
51 }