dev-qt/qtpositioning: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / media-gfx / gif2apng / gif2apng-1.9-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="create an APNG from a GIF"
9 HOMEPAGE="https://sourceforge.net/projects/gif2apng/"
10 SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
11
12 LICENSE="ZLIB LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="sys-libs/zlib
18         app-arch/zopfli:="
19 DEPEND="${RDEPEND}
20         app-arch/unzip"
21
22 S=${WORKDIR}
23
24 PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
25
26 src_prepare() {
27         default
28
29         # remove bundled libs
30         rm -r zlib zopfli || die
31
32         tc-export CC
33 }
34
35 src_install() {
36         dobin ${PN}
37         dodoc readme.txt
38 }