Use https by default
[gentoo.git] / media-gfx / geeqie / geeqie-1.2-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools base eutils
7
8 DESCRIPTION="A lightweight GTK image viewer forked from GQview"
9 HOMEPAGE="http://www.geeqie.org"
10 # Grab from tag snapshot: http://www.geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git
11 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc x86"
16 IUSE="doc exif jpeg lcms lirc lua tiff xmp"
17
18 RDEPEND="x11-libs/gtk+:2
19         virtual/libintl
20         doc? ( app-text/gnome-doc-utils )
21         jpeg? ( virtual/jpeg:0 )
22         lcms? ( media-libs/lcms:2 )
23         lirc? ( app-misc/lirc )
24         lua? ( >=dev-lang/lua-5.1:= )
25         xmp? ( >=media-gfx/exiv2-0.17:=[xmp] )
26         !xmp? ( exif? ( >=media-gfx/exiv2-0.17 ) )
27         tiff? ( media-libs/tiff:0 )"
28 DEPEND="${RDEPEND}
29         virtual/pkgconfig
30         dev-util/intltool
31         sys-devel/gettext"
32
33 S=${WORKDIR}/${PN}-${PN}
34
35 PATCHES=(
36         "${FILESDIR}"/${P}-fix-lcms2-integration.patch
37         "${FILESDIR}"/${P}-fix_version.patch
38 )
39
40 src_prepare() {
41         base_src_prepare
42
43         epatch_user
44
45         eautoreconf
46 }
47
48 src_configure() {
49         # Force disable experimental stuff
50         local myconf="--disable-dependency-tracking
51                 --with-readmedir=/usr/share/doc/${PF}
52                 --disable-gtk3
53                 --disable-clutter
54                 --disable-gps
55                 $(use_enable jpeg)
56                 $(use_enable lcms)
57                 $(use_enable lua)
58                 $(use_enable lirc)
59                 $(use_enable tiff)"
60
61         if use exif || use xmp; then
62                 myconf="${myconf} --enable-exiv2"
63         else
64                 myconf="${myconf} --disable-exiv2"
65         fi
66
67         econf ${myconf}
68 }
69
70 src_install() {
71         emake DESTDIR="${D}" install
72         rm -f "${D}/usr/share/doc/${MY_P}/COPYING"
73 }
74
75 pkg_postinst() {
76         elog "Some plugins may require additional packages"
77         elog "- Image rotate plugin: media-gfx/fbida (JPEG), media-gfx/imagemagick (TIFF/PNG)"
78         elog "- RAW images plugin: media-gfx/ufraw"
79 }