dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / media-gfx / frogr / frogr-1.5.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit gnome.org gnome2-utils meson xdg
7
8 DESCRIPTION="flickr applications for GNOME"
9 HOMEPAGE="https://live.gnome.org/Frogr"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 RDEPEND="
17         >=dev-libs/glib-2.44:2
18         >=dev-libs/json-glib-1.2
19         >=x11-libs/gtk+-3.16:3[introspection]
20         >=media-libs/libexif-0.6.14
21         >=dev-libs/libxml2-2.6.8:2
22         media-libs/gstreamer:1.0
23         >=net-libs/libsoup-2.34:2.4
24         >=dev-libs/libgcrypt-1.5:*
25 "
26 DEPEND="${RDEPEND}
27         >=sys-devel/gettext-0.19.7
28         virtual/pkgconfig
29 "
30 # TODO add a useflag for enable-video or header-bar???
31
32 src_configure() {
33         local emesonargs=()
34         meson_src_configure
35 }
36
37 pkg_postinst() {
38         xdg_pkg_postinst
39         gnome2_icon_cache_update
40         gnome2_schemas_update
41 }
42
43 pkg_postrm() {
44         gnome2_icon_cache_update
45         xdg_pkg_postrm
46         gnome2_schemas_update
47 }