proj/gentoo: Initial commit
[gentoo.git] / media-gfx / cthumb / cthumb-4.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 DESCRIPTION="Create a statical HTML Image gallery with captions for each image"
6
7 HOMEPAGE="http://cthumb.sourceforge.net"
8 SRC_URI="mirror://sourceforge/cthumb/${P}.tar.gz"
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="alpha ~amd64 ppc ~sparc x86"
12 IUSE=""
13
14 DEPEND="dev-perl/URI
15         dev-perl/HTML-Parser
16         media-libs/netpbm"
17
18 src_compile() {
19         ./configure \
20                 --host=${CHOST} \
21                 --prefix=/usr \
22                 --infodir=/usr/share/info \
23                 --mandir=/usr/share/man || die "./configure failed"
24 }
25
26 src_install () {
27         make \
28                 prefix=${D}/usr \
29                 mandir=${D}/usr/share/man \
30                 infodir=${D}/usr/share/info \
31                 install || die
32 }