dev-qt/qtpositioning: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / media-gfx / apngopt / apngopt-1.4.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="optimize APNG images"
9 HOMEPAGE="https://sourceforge.net/projects/apng/"
10 SRC_URI="mirror://sourceforge/apng/${P}-src.zip"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="sys-libs/zlib
18         >=app-arch/zopfli-1.0.1-r2:=
19         media-libs/libpng:0="
20 DEPEND="${RDEPEND}
21         app-arch/unzip"
22
23 S=${WORKDIR}
24
25 PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
26
27 src_prepare() {
28         default
29         rm -rf libpng zlib zopfli || die
30 }
31
32 src_compile() {
33         emake CC="$(tc-getCC)" ${PN}
34 }
35
36 src_install() {
37         dobin ${PN}
38         dodoc readme.txt
39 }