Merge remote-tracking branch 'remotes/PPed72/net-p2p/deluge_fix_live_ebuild'
[gentoo.git] / media-fonts / stix-fonts / stix-fonts-1.0.0-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit font
6
7 DESCRIPTION="Comprehensive OpenType font set of mathematical symbols and alphabets"
8 HOMEPAGE="http://www.stixfonts.org/"
9 SRC_URI="mirror://gentoo/STIXv${PV}.zip"
10
11 LICENSE="OFL-1.1"
12 SLOT="0"
13 KEYWORDS="amd64 arm ~mips ppc ~ppc64 x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
14 IUSE="doc"
15
16 DEPEND="app-arch/unzip"
17 RDEPEND=""
18
19 S="${WORKDIR}/STIXv${PV}"
20 FONT_SUFFIX="otf"
21 FONT_S="${S}/Fonts"
22 FONT_CONF=( "${FILESDIR}"/61-stix.conf )
23
24 src_install() {
25         # DOCS can't do files with spaces so handle it ourselves
26         font_src_install
27         dodoc "STIX Font Release Documentation 2010.pdf"
28         use doc && dodoc "${S}"/Glyphs/*.pdf
29 }
30
31 RESTRICT="strip binchecks"