Revert "media-fonts/zh-kcfonts: Add missing FONT_S assignment."
[gentoo.git] / media-fonts / fontawesome / fontawesome-4.7.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit font
7
8 REPO_PN="Font-Awesome"
9
10 DESCRIPTION="The iconic font"
11 HOMEPAGE="http://fontawesome.io"
12 SRC_URI="https://github.com/FortAwesome/${REPO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="CC-BY-3.0 OFL-1.1"
15 SLOT="0/4"
16 KEYWORDS="amd64 arm arm64 x86"
17 IUSE="+otf +ttf"
18
19 REQUIRED_USE="|| ( otf ttf )"
20
21 DEPEND=""
22 RDEPEND=""
23
24 S="${WORKDIR}/${REPO_PN}-${PV}"
25
26 FONT_S="${S}/fonts"
27 FONT_SUFFIX=""
28
29 src_configure() {
30         use otf && FONT_SUFFIX+="otf "
31         use ttf && FONT_SUFFIX+="ttf "
32 }