Revert "media-fonts/bitstream-cyberbit: Add missing FONT_S assignment."
[gentoo.git] / media-fonts / corefonts / corefonts-1-r7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit font
6
7 DESCRIPTION="Microsoft's TrueType core fonts"
8 HOMEPAGE="http://corefonts.sourceforge.net/"
9 SRC_URI="mirror://gentoo/EUupdate.EXE
10         mirror://sourceforge/corefonts/andale32.exe
11         mirror://sourceforge/corefonts/arialb32.exe
12         mirror://sourceforge/corefonts/comic32.exe
13         mirror://sourceforge/corefonts/courie32.exe
14         mirror://sourceforge/corefonts/georgi32.exe
15         mirror://sourceforge/corefonts/impact32.exe
16         mirror://sourceforge/corefonts/webdin32.exe
17         mirror://sourceforge/corefonts/wd97vwr32.exe"
18
19 LICENSE="MSttfEULA"
20 SLOT="0"
21 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
22 IUSE="X tahoma"
23
24 DEPEND="app-arch/cabextract"
25
26 S=${WORKDIR}
27 FONT_S=${WORKDIR}
28 FONT_SUFFIX="ttf"
29
30 src_unpack() {
31         for exe in ${A} ; do
32                 echo ">>> Unpacking ${exe} to ${WORKDIR}"
33                 cabextract --lowercase "${DISTDIR}"/${exe} > /dev/null \
34                         || die "failed to unpack ${exe}"
35         done
36         if use tahoma; then
37                 cabextract -F 'tahoma.ttf' "${WORKDIR}/viewer1.cab" > /dev/null \
38                         || die "failed to unpack tahoma.ttf"
39         fi
40 }
41
42 src_install() {
43         font_src_install
44         # The license explicitly states that the license must be distributed with the
45         # fonts. The only way to do that for the binpkg is to include it.
46         dodoc license.txt
47 }