fb7b7a3f159f3b05f09ee5f9fcbb8836175cef95
[gentoo.git] / mate-base / mate-settings-daemon / mate-settings-daemon-1.8.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 GCONF_DEBUG="yes"
8 GNOME2_LA_PUNT="yes"
9
10 inherit eutils gnome2 versionator
11
12 MATE_BRANCH="$(get_version_component_range 1-2)"
13
14 SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
15 DESCRIPTION="MATE Settings Daemon"
16 HOMEPAGE="http://mate-desktop.org"
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 KEYWORDS="amd64 ~x86"
21
22 IUSE="X debug libnotify policykit pulseaudio smartcard"
23
24 RDEPEND=">=dev-libs/dbus-glib-0.74:0
25         >=dev-libs/glib-2.17.3:2
26         >=mate-base/libmatekbd-1.8:0
27         >=mate-base/mate-desktop-1.8.1:0
28         media-libs/fontconfig:1.0
29         >=gnome-base/dconf-0.13.4:0
30         x11-libs/cairo:0
31         x11-libs/gdk-pixbuf:2
32         >=x11-libs/gtk+-2.24:2
33         x11-libs/libX11:0
34         x11-libs/libXi:0
35         x11-libs/libXext:0
36         x11-libs/libXxf86misc:0
37         >=x11-libs/libxklavier-5:0
38         virtual/libintl:0
39         libnotify? ( >=x11-libs/libnotify-0.7:0 )
40         policykit? (
41                 >=dev-libs/dbus-glib-0.71:0
42                 >=sys-apps/dbus-1.1.2:0
43                 >=sys-auth/polkit-0.97:0
44         )
45         pulseaudio? (
46                 media-libs/libcanberra:0[gtk]
47                 >=media-sound/pulseaudio-0.9.15:0
48         )
49         !pulseaudio? (
50                 >=media-libs/gstreamer-0.10.1.2:0.10
51                 >=media-libs/gst-plugins-base-0.10.1.2:0.10
52         )
53         smartcard? ( >=dev-libs/nss-3.11.2:0 )"
54
55 DEPEND="${RDEPEND}
56         >=dev-util/intltool-0.37.1:0
57         sys-devel/gettext:0
58         virtual/pkgconfig:0
59         x11-proto/inputproto:0
60         x11-proto/xproto:0"
61
62 src_prepare() {
63         # More network filesystems not to monitor, upstream bug #606421
64         epatch "${FILESDIR}/${PN}-1.4.0-netfs-monitor.patch"
65
66         # mouse: Use event driven mode for syndaemon
67         epatch "${FILESDIR}/${PN}-1.2.0-syndaemon-mode.patch"
68
69         gnome2_src_prepare
70 }
71
72 src_configure() {
73         gnome2_src_configure \
74                 $(use_with libnotify) \
75                 $(use_enable debug) \
76                 $(use_enable policykit polkit) \
77                 $(use_enable pulseaudio pulse) \
78                 $(use_enable !pulseaudio gstreamer) \
79                 $(use_enable smartcard smartcard-support) \
80                 $(use_with X x)
81 }
82
83 DOCS="AUTHORS NEWS ChangeLog"