dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / mate-base / mate-desktop / mate-desktop-1.24.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MATE_LA_PUNT="yes"
7
8 inherit mate
9
10 if [[ ${PV} != 9999 ]]; then
11         KEYWORDS="~amd64 ~arm ~arm64 ~x86"
12 fi
13
14 DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
15 LICENSE="FDL-1.1 GPL-2+ LGPL-2+ MIT-with-advertising"
16 SLOT="0"
17
18 IUSE="X debug +introspection startup-notification"
19
20 COMMON_DEPEND="
21         >=dev-libs/glib-2.50:2
22         >=gnome-base/dconf-0.13.4
23         x11-libs/cairo
24         x11-libs/libX11
25         >=x11-libs/libXrandr-1.3
26         >=x11-libs/gtk+-3.22:3[introspection?]
27         introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
28         startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
29
30 RDEPEND="${COMMON_DEPEND}
31         virtual/libintl
32 "
33
34 DEPEND="${COMMON_DEPEND}
35         app-text/docbook-xml-dtd:4.1.2
36         app-text/iso-codes
37         dev-util/gtk-doc
38         dev-util/gtk-doc-am
39         >=sys-devel/gettext-0.19.8:*
40         x11-base/xorg-proto
41         >=x11-libs/gdk-pixbuf-2.36.5
42         virtual/pkgconfig:*"
43
44 src_configure() {
45         mate_src_configure \
46                 --enable-mate-about \
47                 $(use_with X x) \
48                 $(use_enable debug) \
49                 $(use_enable introspection) \
50                 $(use_enable startup-notification)
51 }