dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / mate-base / mate-control-center / mate-control-center-1.24.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MATE_LA_PUNT="yes"
7
8 inherit mate
9
10 if [[ ${PV} != 9999 ]]; then
11         KEYWORDS="~amd64 ~arm ~arm64 ~x86"
12 fi
13
14 DESCRIPTION="The MATE Desktop configuration tool"
15 LICENSE="FDL-1.1+ GPL-2+ LGPL-2+ LGPL-2.1+ HPND"
16 SLOT="0"
17
18 IUSE="accountsservice appindicator debug"
19
20 RDEPEND="
21         dev-libs/atk
22         >=dev-libs/dbus-glib-0.73
23         >=dev-libs/glib-2.50:2
24         dev-libs/libxml2:2
25         >=gnome-base/dconf-0.13.4
26         >=gnome-base/librsvg-2.0:2
27         >=mate-base/libmatekbd-1.17.0
28         >=mate-base/mate-desktop-1.23.2
29         >=mate-base/caja-1.20.0
30         >=mate-base/mate-menus-1.21.0
31         >=mate-base/mate-settings-daemon-1.23.1
32         >=media-libs/fontconfig-1:1.0
33         media-libs/freetype:2
34         media-libs/libcanberra:0[gtk3]
35         >=sys-apps/dbus-1
36         sys-auth/polkit[introspection]
37         x11-apps/xmodmap
38         x11-libs/cairo
39         x11-libs/gdk-pixbuf:2
40         >=x11-libs/gtk+-3.22:3
41         x11-libs/libX11
42         x11-libs/libXScrnSaver
43         x11-libs/libXcursor
44         x11-libs/libXext
45         >=x11-libs/libXi-1.5
46         x11-libs/libXrandr
47         x11-libs/libXrender
48         >=x11-libs/libxklavier-4
49         x11-libs/pango
50         >=x11-wm/marco-1.17.0:=
51         accountsservice? ( sys-apps/accountsservice )
52         appindicator? ( dev-libs/libappindicator:3 )"
53
54 DEPEND="${RDEPEND}
55         app-text/rarian
56         >=app-text/scrollkeeper-dtd-1:1.0
57         app-text/yelp-tools
58         dev-libs/libxml2
59         dev-util/desktop-file-utils
60         dev-util/glib-utils
61         >=sys-devel/gettext-0.19.8:*
62         x11-base/xorg-proto
63         virtual/pkgconfig"
64
65 src_configure() {
66         mate_src_configure \
67                 --disable-update-mimedb \
68                 $(use_enable appindicator) \
69                 $(use_enable debug)
70 }