Merge branch 'pull895'
[gentoo.git] / mate-base / mate / mate-1.10.0-r2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit versionator
8
9 MATE_MV="$(get_version_component_range 1-2)"
10
11 SRC_URI=""
12 DESCRIPTION="Meta ebuild for MATE, a traditional desktop environment"
13 HOMEPAGE="http://mate-desktop.org"
14
15 LICENSE="metapackage"
16
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="+base -bluetooth +notification +themes +extras"
20
21 S="${WORKDIR}"
22
23 RDEPEND="
24         =mate-base/mate-desktop-${MATE_MV}*:0
25         =mate-base/mate-menus-${MATE_MV}*:0
26         =mate-base/mate-panel-${MATE_MV}*:0
27         =mate-base/mate-session-manager-${MATE_MV}*:0
28         =mate-base/mate-settings-daemon-${MATE_MV}*:0
29         =x11-wm/marco-${MATE_MV}*:0
30         base? (
31                 =mate-base/caja-${MATE_MV}*:0
32                 =mate-base/mate-applets-meta-${MATE_MV}*:0
33                 =mate-base/mate-control-center-${MATE_MV}*:0
34                 =mate-extra/mate-media-${MATE_MV}*:0
35                 =x11-misc/mozo-${MATE_MV}*:0
36                 =x11-terms/mate-terminal-${MATE_MV}*:0
37         )
38         bluetooth? ( net-wireless/blueman:0 )
39         themes? (
40                 =x11-themes/mate-backgrounds-${MATE_MV}*:0
41                 =x11-themes/mate-icon-theme-${MATE_MV}*:0
42                 =x11-themes/mate-themes-meta-${MATE_MV}*:0
43         )
44         extras? (
45                 =app-arch/engrampa-${MATE_MV}*:0
46                 =app-editors/pluma-${MATE_MV}*:0
47                 =app-text/atril-${MATE_MV}*:0
48                 gnome-extra/gnome-calculator:0
49                 =mate-extra/caja-extensions-${MATE_MV}*:0
50                 =mate-extra/mate-netbook-${MATE_MV}*:0
51                 =mate-extra/mate-power-manager-${MATE_MV}*:0
52                 =mate-extra/mate-screensaver-${MATE_MV}*:0
53                 =mate-extra/mate-system-monitor-${MATE_MV}*:0
54                 =mate-extra/mate-utils-${MATE_MV}*:0
55                 =media-gfx/eom-${MATE_MV}*:0
56                 =net-analyzer/mate-netspeed-${MATE_MV}*:0
57                 sys-apps/gnome-disk-utility:0
58         )
59 "
60
61 PDEPEND="
62         notification? ( x11-misc/mate-notification-daemon )
63         virtual/notification-daemon:0"
64
65 pkg_postinst() {
66         elog "For installation, usage and troubleshooting details regarding MATE;"
67         elog "read more about it at Gentoo Wiki: https://wiki.gentoo.org/wiki/MATE"
68         elog ""
69         if ! has_version x11-misc/mate-notification-daemon; then
70                 elog "If you experience any issues with notifications, please try using"
71                 elog "x11-misc/mate-notification-daemon instead your currently installed daemon"
72                 elog ""
73         fi
74         elog "MATE 1.10 had some packages renamed, replaced and/or dropped; for more"
75         elog "details, see http://mate-desktop.org/blog/2015-06-11-mate-1-10-released/"
76         elog ""
77         elog "Some packages that are not included in this meta-package but may be of interest:"
78         elog "          mate-extra/caja-dropbox"
79         elog "          mate-extra/mate-user-share"
80 }