mate-base/libmatekbd: amd64 stable wrt bug #625838
[gentoo.git] / mate-base / libmatekbd / libmatekbd-1.18.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MATE_LA_PUNT="yes"
7
8 inherit mate
9
10 if [[ ${PV} != 9999 ]]; then
11         KEYWORDS="amd64 ~arm ~arm64 x86"
12 fi
13
14 DESCRIPTION="MATE keyboard configuration library"
15 LICENSE="LGPL-2"
16 SLOT="0"
17
18 IUSE="X +introspection test"
19
20 COMMON_DEPEND=">=dev-libs/glib-2.36:2
21         x11-libs/cairo:0
22         >=x11-libs/gdk-pixbuf-2.24:2
23         x11-libs/libX11:0
24         >=x11-libs/libxklavier-5.2:0[introspection?]
25         x11-libs/pango:0
26         virtual/libintl:0
27         >=x11-libs/gtk+-3.0:3[introspection?]
28         introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
29
30 RDEPEND="${COMMON_DEPEND}"
31
32 DEPEND="${COMMON_DEPEND}
33         sys-devel/gettext:*
34         >=dev-util/intltool-0.50.1:*
35         virtual/pkgconfig:*"
36
37 src_configure() {
38         mate_src_configure \
39                 $(use_with X x) \
40                 $(use_enable introspection) \
41                 $(use_enable test tests)
42 }