mail-mta/netqmail: stable 1.06-r13 for ppc, bug #721566
[gentoo.git] / mail-mta / esmtp / esmtp-1.2-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="User configurable relay-only Mail Transfer Agent with a sendmail-like syntax"
7 HOMEPAGE="http://esmtp.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
13 IUSE="libressl"
14
15 CDEPEND="
16         net-libs/libesmtp
17         !libressl? ( dev-libs/openssl:0= )
18         libressl? ( dev-libs/libressl:= )
19 "
20 RDEPEND="${CDEPEND}
21         !mail-mta/courier
22         !mail-mta/exim
23         !mail-mta/mini-qmail
24         !mail-mta/msmtp
25         !mail-mta/netqmail
26         !mail-mta/nullmailer
27         !mail-mta/postfix
28         !mail-mta/qmail-ldap
29         !mail-mta/sendmail
30         !mail-mta/ssmtp
31         !mail-mta/opensmtpd
32 "
33 DEPEND="${CDEPEND}
34         sys-devel/flex
35 "
36
37 src_install() {
38         default
39         dodoc AUTHORS ChangeLog NEWS README TODO sample.esmtprc
40 }
41
42 pkg_postinst() {
43         elog "A sample esmtprc file has been installed in /usr/share/doc/${P}"
44 }