sys-apps/pcsc-lite: amd64 stable wrt bug #663594
[gentoo.git] / mail-client / geary / geary-0.12.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 # Keep cmake-utils at the end
6 inherit gnome2 vala cmake-utils
7
8 DESCRIPTION="A lightweight, easy-to-use, feature-rich email client"
9 HOMEPAGE="https://wiki.gnome.org/Apps/Geary"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE="nls"
15
16 DEPEND="
17         >=app-crypt/gcr-3.10.1:0=[gtk,introspection,vala]
18         app-crypt/libsecret
19         app-text/iso-codes
20         dev-db/sqlite:3
21         >=dev-libs/glib-2.42:2[dbus]
22         >=dev-libs/libgee-0.8.5:0.8=
23         dev-libs/libxml2:2
24         dev-libs/gmime:2.6
25         media-libs/libcanberra
26         >=net-libs/webkit-gtk-2.10.0:4=[introspection]
27         >=x11-libs/gtk+-3.14.0:3[introspection]
28         x11-libs/libnotify
29 "
30 RDEPEND="${DEPEND}
31         gnome-base/gsettings-desktop-schemas
32         nls? ( virtual/libintl )
33 "
34 DEPEND="${DEPEND}
35         app-text/gnome-doc-utils
36         dev-util/desktop-file-utils
37         nls? ( sys-devel/gettext )
38         $(vala_depend)
39         virtual/pkgconfig
40 "
41
42 src_prepare() {
43         # https://bugzilla.gnome.org/show_bug.cgi?id=751557
44         sed -i -e 's/vapigen --library/${VAPIGEN} --library/' src/CMakeLists.txt || die
45
46         local i
47         if use nls ; then
48                 if [[ -n "${LINGUAS+x}" ]] ; then
49                         for i in $(cd po ; echo *.po) ; do
50                                 if ! has ${i%.po} ${LINGUAS} ; then
51                                         sed -i -e "/^${i%.po}$/d" po/LINGUAS || die
52                                 fi
53                         done
54                 fi
55         else
56                 sed -i -e 's#add_subdirectory(po)##' CMakeLists.txt || die
57         fi
58
59         cmake-utils_src_prepare
60         gnome2_src_prepare
61         vala_src_prepare
62 }
63
64 src_configure() {
65         local mycmakeargs=(
66                 -DDESKTOP_UPDATE=OFF
67                 -DNO_FATAL_WARNINGS=ON
68                 -DGSETTINGS_COMPILE=OFF
69                 -DICON_UPDATE=OFF
70                 -DVALA_EXECUTABLE="${VALAC}"
71                 -DVAPIGEN="${VAPIGEN}"
72                 -DWITH_UNITY=OFF
73                 -DDESKTOP_VALIDATE=OFF
74         )
75
76         cmake-utils_src_configure
77 }