mail-client/thunderbird: add description for USE=clang to metadata.xml
[gentoo.git] / mail-client / alpine / alpine-2.21.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools toolchain-funcs
6
7 DESCRIPTION="An easy to use text-based based mail and news client"
8 HOMEPAGE="http://www.washington.edu/alpine/ http://repo.or.cz/alpine.git/"
9 GIT_COMMIT="843b2f16abfd949e09b1c5465387b1b0f724994a"
10 MY_P="${PN}-${GIT_COMMIT::7}"
11 SRC_URI="http://repo.or.cz/alpine.git/snapshot/${GIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
12 S="${WORKDIR}/${MY_P}"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="alpha amd64 ia64 ppc sparc x86"
17 IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads"
18
19 DEPEND="virtual/pam
20         >=sys-libs/ncurses-5.1:0=
21         ssl? (
22                 !libressl? ( dev-libs/openssl:0= )
23                 libressl? ( dev-libs/libressl:0= )
24         )
25         ldap? ( net-nds/openldap )
26         kerberos? ( app-crypt/mit-krb5 )
27         spell? ( app-text/aspell )
28 "
29 RDEPEND="${DEPEND}
30         app-misc/mime-types
31         !onlyalpine? ( !mail-client/pine )
32         !<=net-mail/uw-imap-2004g
33 "
34
35 src_prepare() {
36         default
37         eautoreconf
38 }
39
40 src_configure() {
41         myconf=(
42                 --without-tcl
43                 --with-system-pinerc="${EPREFIX}"/etc/pine.conf
44                 --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
45         )
46
47         if use ssl; then
48                 myconf+=(
49                         --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
50                         --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
51                         --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
52                 )
53         fi
54         econf \
55                 $(use_with ldap) \
56                 $(use_with ssl) \
57                 $(use_with passfile passfile .pinepwd) \
58                 $(use_with kerberos krb5) \
59                 $(use_with threads pthread) \
60                 $(use_with spell interactive-spellcheck /usr/bin/aspell) \
61                 $(use_enable nls) \
62                 $(use_with ipv6) \
63                 $(use_with smime) \
64                 "${myconf[@]}"
65 }
66
67 src_compile() {
68         emake AR=$(tc-getAR)
69 }
70
71 src_install() {
72         if use onlyalpine ; then
73                 dobin alpine/alpine
74                 doman doc/man1/alpine.1
75         else
76                 emake DESTDIR="${D}" install
77                 doman doc/man1/*.1
78         fi
79
80         dodoc NOTICE README*
81
82         if use doc ; then
83                 dodoc doc/brochure.txt
84
85                 dodoc doc/tech-notes/tech-notes.txt
86                 newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
87                 newdoc "${S}/doc/mime.types" mime.types.sample
88                 docinto html/tech-notes
89                 dohtml -r doc/tech-notes/
90                 docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
91         fi
92 }