dev-python/ovsdbapp: 0.17.2 bump
[gentoo.git] / lxde-base / menu-cache / menu-cache-1.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Library to create and utilize caches to speed up freedesktop application menus"
7 HOMEPAGE="https://lxde.org/"
8 SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
9
10 LICENSE="LGPL-2.1+"
11 # ABI is v2. See Makefile.am
12 SLOT="0/2"
13 KEYWORDS="~alpha amd64 arm ~arm64 ~mips ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
14 IUSE=""
15
16 RDEPEND="dev-libs/glib:2
17         x11-libs/libfm-extra"
18 DEPEND="${RDEPEND}
19         sys-devel/gettext
20         virtual/pkgconfig"
21
22 # Fix for gcc 10 / -fno-common
23 # https://github.com/lxde/menu-cache/pull/19
24 PATCHES="${FILESDIR}/${P}-fno-common.diff"
25
26 src_configure() {
27         econf "--disable-static"
28 }