dev-python/jaraco-collections: keyworded 3.0.0 for ia64, bug #717946
[gentoo.git] / lxde-base / lxappearance / lxappearance-0.6.3-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PLOCALES="ar be bg ca cs da de el en_GB es et eu fa fi fo fr gl he hr hu id is
7 it ja kk ko lg lt nl pa pl pt_BR pt ro ru sl sr@latin sr sv te tr tt_RU ug uk
8 ur_PK ur vi zh_CN zh_TW"
9
10 PLOCALE_BACKUP="en_GB"
11
12 inherit l10n
13
14 DESCRIPTION="LXDE GTK+ theme switcher"
15 HOMEPAGE="https://wiki.lxde.org/en/LXAppearance"
16 SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
17
18 LICENSE="GPL-3"
19 SLOT="0"
20 KEYWORDS="~alpha amd64 arm ~arm64 ~mips ppc x86 ~amd64-linux ~x86-linux"
21 IUSE="dbus"
22
23 RDEPEND="x11-libs/gtk+:2
24         dbus? ( dev-libs/dbus-glib )"
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig
27         dev-util/intltool
28         sys-devel/gettext"
29
30 src_prepare() {
31         default
32
33         export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
34         l10n_get_locales > po/LINGUAS || die
35 }
36
37 src_configure() {
38         econf \
39                 $(use_enable dbus)
40 }