sys-power/thermald: fixes bug #670624
[gentoo.git] / kde-plasma / plasma-nm / plasma-nm-5.14.2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="KDE Plasma applet for NetworkManager"
9 LICENSE="GPL-2 LGPL-2.1"
10 KEYWORDS="~amd64 ~arm ~x86"
11 IUSE="modemmanager openconnect teamd"
12
13 DEPEND="
14         $(add_frameworks_dep kcompletion)
15         $(add_frameworks_dep kconfig)
16         $(add_frameworks_dep kconfigwidgets)
17         $(add_frameworks_dep kcoreaddons)
18         $(add_frameworks_dep kdbusaddons)
19         $(add_frameworks_dep kdeclarative)
20         $(add_frameworks_dep ki18n)
21         $(add_frameworks_dep kiconthemes)
22         $(add_frameworks_dep kio)
23         $(add_frameworks_dep kitemviews)
24         $(add_frameworks_dep knotifications)
25         $(add_frameworks_dep kservice)
26         $(add_frameworks_dep kwallet)
27         $(add_frameworks_dep kwidgetsaddons)
28         $(add_frameworks_dep kwindowsystem)
29         $(add_frameworks_dep kxmlgui)
30         $(add_frameworks_dep networkmanager-qt 'teamd=')
31         $(add_frameworks_dep plasma)
32         $(add_frameworks_dep solid)
33         $(add_qt_dep qtdbus)
34         $(add_qt_dep qtdeclarative)
35         $(add_qt_dep qtgui)
36         $(add_qt_dep qtnetwork)
37         $(add_qt_dep qtwidgets)
38         >=app-crypt/qca-2.1.1:2[qt5(+)]
39         net-misc/networkmanager[teamd=]
40         modemmanager? (
41                 $(add_frameworks_dep modemmanager-qt)
42                 $(add_qt_dep qtxml)
43                 net-misc/mobile-broadband-provider-info
44         )
45         openconnect? (
46                 $(add_qt_dep qtxml)
47                 net-misc/networkmanager-openconnect
48                 net-vpn/openconnect:=
49         )
50 "
51 RDEPEND="${DEPEND}
52         $(add_plasma_dep kde-cli-tools)
53         !kde-plasma/plasma-nm:4
54 "
55
56 src_configure() {
57         local mycmakeargs=(
58                 -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
59                 $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
60                 $(cmake-utils_use_find_package openconnect OpenConnect)
61         )
62
63         kde5_src_configure
64 }
65
66 pkg_postinst() {
67         kde5_pkg_postinst
68
69         if ! has_version "kde-plasma/plasma-workspace:5"; then
70                 elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
71                 elog "However, the networkmanagement KCM can be called from either systemsettings"
72                 elog "or manually: $ kcmshell5 kcm_networkmanagement"
73         fi
74 }