kde-plasma/plasma-sdk: arm64 stable wrt bug #721452
[gentoo.git] / kde-plasma / plasma-meta / plasma-meta-5.18.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Merge this to pull in all Plasma 5 packages"
7 HOMEPAGE="https://kde.org/plasma-desktop"
8
9 LICENSE="metapackage"
10 SLOT="5"
11 KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
12 IUSE="bluetooth +browser-integration crypt +desktop-portal discover
13 +display-manager elogind grub gtk +handbook +kwallet +legacy-systray
14 +networkmanager plymouth pulseaudio qrcode +sddm sdk systemd thunderbolt +wallpapers"
15
16 REQUIRED_USE="?? ( elogind systemd )"
17
18 RDEPEND="
19         >=kde-plasma/breeze-${PV}:${SLOT}
20         >=kde-plasma/drkonqi-${PV}:${SLOT}
21         >=kde-plasma/kactivitymanagerd-${PV}:${SLOT}
22         >=kde-plasma/kde-cli-tools-${PV}:${SLOT}
23         >=kde-plasma/kdecoration-${PV}:${SLOT}
24         >=kde-plasma/kdeplasma-addons-${PV}:${SLOT}
25         >=kde-plasma/kgamma-${PV}:${SLOT}
26         >=kde-plasma/khotkeys-${PV}:${SLOT}
27         >=kde-plasma/kinfocenter-${PV}:${SLOT}
28         >=kde-plasma/kmenuedit-${PV}:${SLOT}
29         >=kde-plasma/kscreen-${PV}:${SLOT}
30         >=kde-plasma/kscreenlocker-${PV}:${SLOT}
31         >=kde-plasma/ksshaskpass-${PV}:${SLOT}
32         >=kde-plasma/ksysguard-${PV}:${SLOT}
33         >=kde-plasma/kwayland-integration-${PV}:${SLOT}
34         >=kde-plasma/kwin-${PV}:${SLOT}
35         >=kde-plasma/kwrited-${PV}:${SLOT}
36         >=kde-plasma/libkscreen-${PV}:${SLOT}
37         >=kde-plasma/libksysguard-${PV}:${SLOT}
38         >=kde-plasma/milou-${PV}:${SLOT}
39         >=kde-plasma/oxygen-${PV}:${SLOT}
40         >=kde-plasma/plasma-desktop-${PV}:${SLOT}
41         >=kde-plasma/plasma-integration-${PV}:${SLOT}
42         >=kde-plasma/plasma-workspace-${PV}:${SLOT}
43         >=kde-plasma/polkit-kde-agent-${PV}:${SLOT}
44         >=kde-plasma/powerdevil-${PV}:${SLOT}
45         >=kde-plasma/systemsettings-${PV}:${SLOT}
46         >=kde-plasma/user-manager-${PV}:${SLOT}
47         sys-apps/dbus[elogind?,systemd?]
48         sys-auth/polkit[elogind?,systemd?]
49         sys-fs/udisks:2[elogind?,systemd?]
50         bluetooth? ( >=kde-plasma/bluedevil-${PV}:${SLOT} )
51         browser-integration? ( >=kde-plasma/plasma-browser-integration-${PV}:${SLOT} )
52         crypt? ( >=kde-plasma/plasma-vault-${PV}:${SLOT} )
53         desktop-portal? ( >=kde-plasma/xdg-desktop-portal-kde-${PV}:${SLOT} )
54         discover? ( >=kde-plasma/discover-${PV}:${SLOT} )
55         display-manager? (
56                 sddm? (
57                         >=kde-plasma/sddm-kcm-${PV}:${SLOT}
58                         x11-misc/sddm[elogind?,systemd?]
59                 )
60                 !sddm? ( x11-misc/lightdm )
61         )
62         grub? ( >=kde-plasma/breeze-grub-${PV}:${SLOT} )
63         gtk? (
64                 >=kde-plasma/breeze-gtk-${PV}:${SLOT}
65                 >=kde-plasma/kde-gtk-config-${PV}:${SLOT}
66         )
67         handbook? ( kde-apps/khelpcenter:5 )
68         kwallet? ( >=kde-plasma/kwallet-pam-${PV}:${SLOT} )
69         legacy-systray? ( >=kde-plasma/xembed-sni-proxy-${PV}:${SLOT} )
70         networkmanager? (
71                 >=kde-plasma/plasma-nm-${PV}:${SLOT}
72                 net-misc/networkmanager[elogind?,systemd?]
73                 qrcode? ( kde-frameworks/prison[qml] )
74         )
75         plymouth? (
76                 >=kde-plasma/breeze-plymouth-${PV}:${SLOT}
77                 >=kde-plasma/plymouth-kcm-${PV}:${SLOT}
78         )
79         pulseaudio? ( >=kde-plasma/plasma-pa-${PV}:${SLOT} )
80         sdk? ( >=kde-plasma/plasma-sdk-${PV}:${SLOT} )
81         thunderbolt? ( >=kde-plasma/plasma-thunderbolt-${PV}:${SLOT} )
82         wallpapers? ( >=kde-plasma/plasma-workspace-wallpapers-${PV}:${SLOT} )
83 "
84
85 pkg_postinst() {
86         has_version sys-auth/consolekit || return
87         use elogind || use systemd && return
88         ewarn "An existing installation of sys-auth/consolekit was detected even though"
89         ewarn "${PN} was configured with USE $(usex elogind elogind systemd)."
90         ewarn "There can only be one session manager at runtime, otherwise random issues"
91         ewarn "may occur. Please make sure USE consolekit is nowhere enabled in make.conf"
92         ewarn "or package.use and remove sys-auth/consolekit before raising bugs."
93         ewarn "For more information, visit https://wiki.gentoo.org/wiki/KDE"
94 }