app-office/pybliographer: Drop old
[gentoo.git] / kde-plasma / plasma-integration / plasma-integration-5.15.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 VIRTUALX_REQUIRED="test"
7 inherit kde5
8
9 DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
10 LICENSE="LGPL-2+"
11 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
12 IUSE=""
13
14 DEPEND="
15         $(add_frameworks_dep kcompletion)
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kconfigwidgets)
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep ki18n)
20         $(add_frameworks_dep kiconthemes)
21         $(add_frameworks_dep kio)
22         $(add_frameworks_dep kjobwidgets)
23         $(add_frameworks_dep knotifications)
24         $(add_frameworks_dep kwayland)
25         $(add_frameworks_dep kwidgetsaddons)
26         $(add_frameworks_dep kwindowsystem)
27         $(add_frameworks_dep kxmlgui)
28         $(add_plasma_dep breeze)
29         $(add_qt_dep qtdbus)
30         $(add_qt_dep qtgui 'dbus' '' '5=')
31         $(add_qt_dep qtquickcontrols2)
32         $(add_qt_dep qtwidgets)
33         $(add_qt_dep qtx11extras)
34         x11-libs/libXcursor
35         x11-libs/libxcb
36 "
37 RDEPEND="${DEPEND}
38         media-fonts/hack
39         media-fonts/noto
40 "
41
42 # requires running kde environment
43 RESTRICT+=" test"