997ee820c5c4cd0122e413b4d4cea4b131da04ba
[gentoo.git] / kde-plasma / plasma-browser-integration / plasma-browser-integration-5.14.2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="Integrate Chrome/Firefox better into Plasma through browser extensions"
9
10 LICENSE="GPL-3+"
11 KEYWORDS="~amd64 ~arm ~x86"
12 IUSE=""
13
14 DEPEND="
15         $(add_frameworks_dep kactivities)
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kcoreaddons)
18         $(add_frameworks_dep kdbusaddons)
19         $(add_frameworks_dep ki18n)
20         $(add_frameworks_dep kio)
21         $(add_frameworks_dep knotifications)
22         $(add_frameworks_dep krunner)
23         $(add_frameworks_dep kwindowsystem)
24         $(add_qt_dep qtdbus)
25         $(add_qt_dep qtgui)
26         $(add_qt_dep qtwidgets)
27 "
28 RDEPEND="${DEPEND}"
29
30 src_configure() {
31         local mycmakeargs=(
32                 -DMOZILLA_DIR="${EPREFIX}/usr/$(get_libdir)/mozilla"
33         )
34
35         kde5_src_configure
36 }