sys-power/thermald: fixes bug #670624
[gentoo.git] / kde-plasma / oxygen / oxygen-5.14.2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="Oxygen visual style for the Plasma desktop"
9 HOMEPAGE="https://cgit.kde.org/oxygen.git"
10 KEYWORDS="~amd64 ~arm ~x86"
11 IUSE="wayland"
12
13 COMMON_DEPEND="
14         $(add_frameworks_dep frameworkintegration)
15         $(add_frameworks_dep kcmutils)
16         $(add_frameworks_dep kcompletion)
17         $(add_frameworks_dep kconfig)
18         $(add_frameworks_dep kconfigwidgets)
19         $(add_frameworks_dep kcoreaddons)
20         $(add_frameworks_dep kguiaddons)
21         $(add_frameworks_dep ki18n)
22         $(add_frameworks_dep kwidgetsaddons)
23         $(add_frameworks_dep kwindowsystem)
24         $(add_plasma_dep kdecoration)
25         $(add_qt_dep qtdbus)
26         $(add_qt_dep qtdeclarative)
27         $(add_qt_dep qtgui)
28         $(add_qt_dep qtwidgets)
29         $(add_qt_dep qtx11extras)
30         x11-libs/libxcb
31         wayland? ( $(add_frameworks_dep kwayland) )
32 "
33 DEPEND="${COMMON_DEPEND}
34         $(add_frameworks_dep kservice)
35 "
36 RDEPEND="${COMMON_DEPEND}
37         $(add_plasma_dep kde-cli-tools)
38         !kde-plasma/kdebase-cursors:4
39 "
40
41 src_configure() {
42         local mycmakeargs=(
43                 $(cmake-utils_use_find_package wayland KF5Wayland)
44         )
45         kde5_src_configure
46 }