kde-plasma/plasma-workspace: Drop translations of Plasma session name
[gentoo.git] / kde-plasma / ksshaskpass / ksshaskpass-5.17.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit kde5
7
8 DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
9 HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
10 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
11 IUSE=""
12
13 DEPEND="
14         $(add_frameworks_dep kcoreaddons)
15         $(add_frameworks_dep ki18n)
16         $(add_frameworks_dep kwallet)
17         $(add_frameworks_dep kwidgetsaddons)
18         $(add_qt_dep qtwidgets)
19 "
20 RDEPEND="${DEPEND}"
21
22 src_install() {
23         kde5_src_install
24
25         insinto /etc/xdg/plasma-workspace/env/
26         doins "${FILESDIR}/05-ksshaskpass.sh"
27 }
28
29 pkg_postinst() {
30         kde5_pkg_postinst
31
32         elog "${PN} has been installed as your default askpass application"
33         elog "for Plasma 5 sessions."
34         elog "If that's not desired, select the one you want to use in"
35         elog
36         elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh (ATTN: Path moved!)"
37         elog
38         elog "In order to have ssh-agent start with Plasma 5, do the following:"
39         elog " * Copy the necessary files to your home directory:"
40         elog "   - cp /etc/plasma/startup/10-agent-startup.sh ~/.config/plasma-workspace/env/"
41         elog "   - cp /etc/plasma/shutdown/10-agent-shutdown.sh ~/.config/plasma-workspace/shutdown/"
42         elog " * Edit 10-agent-startup.sh and uncomment the lines enabling ssh-agent."
43         elog " * In 10-agent-shutdown.sh uncomment the respective lines to properly kill"
44         elog "   the agent when the session ends."
45 }