kde-plasma: Version bump KDE Plasma 5.12.5
[gentoo.git] / kde-plasma / ksshaskpass / ksshaskpass-5.12.4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
9 HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
10 KEYWORDS="~amd64 ~arm ~x86"
11 IUSE=""
12
13 DEPEND="
14         $(add_frameworks_dep kcoreaddons)
15         $(add_frameworks_dep ki18n)
16         $(add_frameworks_dep kwallet)
17         $(add_frameworks_dep kwidgetsaddons)
18         $(add_qt_dep qtwidgets)
19 "
20 RDEPEND="
21         ${DEPEND}
22         !kde-plasma/ksshaskpass:4
23 "
24
25 src_install() {
26         kde5_src_install
27
28         insinto /etc/plasma/startup
29         doins "${FILESDIR}/05-ksshaskpass.sh"
30 }
31
32 pkg_postinst() {
33         kde5_pkg_postinst
34
35         elog ""
36         elog "In order to have ssh-agent start at kde startup,"
37         elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
38         elog "the lines enabling ssh-agent."
39         elog
40         elog "If you do so, do not forget to uncomment the respective"
41         elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
42         elog "properly kill the agent when the session ends."
43         elog
44         elog "${PN} has been installed as your default askpass application"
45         elog "for Plasma 5 sessions."
46         elog "If that's not desired, select the one you want to use in"
47         elog "/etc/plasma/startup/05-ksshaskpass.sh"
48         elog ""
49 }