kde-plasma/plasma-workspace: Drop translations of Plasma session name
[gentoo.git] / kde-plasma / kscreen / kscreen-5.17.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_TEST="forceoptional"
7 inherit kde5
8
9 DESCRIPTION="KDE Plasma screen management"
10 HOMEPAGE="https://cgit.kde.org/kscreen.git"
11
12 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
13 IUSE=""
14
15 DEPEND="
16         $(add_frameworks_dep kcmutils)
17         $(add_frameworks_dep kconfig)
18         $(add_frameworks_dep kconfigwidgets)
19         $(add_frameworks_dep kcoreaddons)
20         $(add_frameworks_dep kdeclarative)
21         $(add_frameworks_dep kdbusaddons)
22         $(add_frameworks_dep kglobalaccel)
23         $(add_frameworks_dep ki18n)
24         $(add_frameworks_dep kiconthemes)
25         $(add_frameworks_dep kwidgetsaddons)
26         $(add_frameworks_dep kxmlgui)
27         $(add_frameworks_dep plasma)
28         $(add_plasma_dep libkscreen)
29         $(add_qt_dep qtdbus)
30         $(add_qt_dep qtdeclarative 'widgets')
31         $(add_qt_dep qtgui)
32         $(add_qt_dep qtwidgets)
33 "
34 RDEPEND="${DEPEND}
35         $(add_plasma_dep kde-cli-tools)
36         $(add_qt_dep qtgraphicaleffects)
37 "
38
39 # bug #580440, last checked 5.6.3
40 RESTRICT+=" test"