e201e30c3a2164c0b13fd6f86f2f615bc5c45fef
[gentoo.git] / kde-plasma / kscreen / kscreen-5.13.4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_TEST="forceoptional"
7 inherit kde5
8
9 DESCRIPTION="KDE Plasma screen management"
10 HOMEPAGE="https://cgit.kde.org/kscreen.git"
11
12 KEYWORDS="~amd64 ~arm ~x86"
13 IUSE=""
14
15 DEPEND="
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kconfigwidgets)
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep kdeclarative)
20         $(add_frameworks_dep kdbusaddons)
21         $(add_frameworks_dep kglobalaccel)
22         $(add_frameworks_dep ki18n)
23         $(add_frameworks_dep kiconthemes)
24         $(add_frameworks_dep kwidgetsaddons)
25         $(add_frameworks_dep kxmlgui)
26         $(add_frameworks_dep plasma)
27         $(add_plasma_dep libkscreen)
28         $(add_qt_dep qtdbus)
29         $(add_qt_dep qtdeclarative 'widgets')
30         $(add_qt_dep qtgui)
31         $(add_qt_dep qtwidgets)
32 "
33 RDEPEND="${DEPEND}
34         $(add_plasma_dep kde-cli-tools)
35         $(add_qt_dep qtgraphicaleffects)
36         !kde-plasma/kscreen:4
37 "
38
39 # bug #580440, last checked 5.6.3
40 RESTRICT+=" test"