kde-plasma/plasma-workspace: Drop translations of Plasma session name
[gentoo.git] / kde-plasma / kmenuedit / kmenuedit-5.17.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_HANDBOOK="forceoptional"
7 inherit kde5
8
9 DESCRIPTION="KDE Plasma menu editor"
10 HOMEPAGE="https://cgit.kde.org/kmenuedit.git"
11 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
12 IUSE="+hotkeys"
13
14 RDEPEND="
15         $(add_frameworks_dep kcompletion)
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kconfigwidgets)
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep kdbusaddons)
20         $(add_frameworks_dep kdelibs4support)
21         $(add_frameworks_dep ki18n)
22         $(add_frameworks_dep kiconthemes)
23         $(add_frameworks_dep kio)
24         $(add_frameworks_dep kservice)
25         $(add_frameworks_dep kwidgetsaddons)
26         $(add_frameworks_dep kxmlgui)
27         $(add_frameworks_dep sonnet)
28         $(add_qt_dep qtdbus)
29         $(add_qt_dep qtgui)
30         $(add_qt_dep qtwidgets)
31         $(add_qt_dep qtxml)
32         hotkeys? ( $(add_plasma_dep khotkeys) )
33 "
34 DEPEND="${RDEPEND}
35         $(add_frameworks_dep kinit)
36 "
37
38 src_configure() {
39         local mycmakeargs=(
40                 $(cmake-utils_use_find_package hotkeys KHotKeysDBusInterface)
41         )
42
43         kde5_src_configure
44 }