kde-plasma/kscreenlocker: arm64 stable wrt bug #721452
[gentoo.git] / kde-plasma / kde-gtk-config / kde-gtk-config-5.18.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KFMIN=5.66.0
7 PVCUT=$(ver_cut 1-3)
8 QTMIN=5.12.3
9 VIRTUALX_REQUIRED="test"
10 inherit ecm kde.org
11
12 DESCRIPTION="GTK2 and GTK3 configurator for KDE Plasma"
13 HOMEPAGE="https://invent.kde.org/plasma/kde-gtk-config"
14
15 LICENSE="GPL-3"
16 SLOT="5"
17 KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
18 IUSE=""
19
20 DEPEND="
21         dev-libs/glib:2
22         >=dev-qt/qtdbus-${QTMIN}:5
23         >=dev-qt/qtgui-${QTMIN}:5
24         gnome-base/gsettings-desktop-schemas
25         >=kde-frameworks/kconfig-${KFMIN}:5
26         >=kde-frameworks/kcoreaddons-${KFMIN}:5
27         >=kde-frameworks/kdbusaddons-${KFMIN}:5
28         >=kde-frameworks/kiconthemes-${KFMIN}:5
29         x11-libs/gtk+:2
30         x11-libs/gtk+:3
31 "
32 RDEPEND="${DEPEND}
33         >=kde-plasma/kde-cli-tools-${PVCUT}:5
34 "
35
36 src_configure() {
37         local mycmakeargs=(
38                 -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
39         )
40
41         ecm_src_configure
42 }
43
44 pkg_postinst() {
45         ecm_pkg_postinst
46         elog "If you notice missing icons in your GTK applications, you may have to install"
47         elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
48         elog "for example."
49 }