sys-power/thermald: fixes bug #670624
[gentoo.git] / kde-plasma / kde-gtk-config / kde-gtk-config-5.14.2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_TEST="forceoptional"
7 VIRTUALX_REQUIRED="test"
8 inherit kde5
9
10 DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
11 HOMEPAGE="https://cgit.kde.org/kde-gtk-config.git"
12 LICENSE="GPL-3"
13 KEYWORDS="~amd64 ~arm ~x86"
14 IUSE=""
15
16 DEPEND="
17         $(add_frameworks_dep karchive)
18         $(add_frameworks_dep kcmutils)
19         $(add_frameworks_dep kconfigwidgets)
20         $(add_frameworks_dep kcoreaddons)
21         $(add_frameworks_dep ki18n)
22         $(add_frameworks_dep kiconthemes)
23         $(add_frameworks_dep kio)
24         $(add_frameworks_dep knewstuff)
25         $(add_frameworks_dep kwidgetsaddons)
26         $(add_qt_dep qtgui)
27         $(add_qt_dep qtwidgets)
28         dev-libs/glib:2
29         gnome-base/gsettings-desktop-schemas
30         x11-libs/gtk+:2
31         x11-libs/gtk+:3
32         x11-libs/libXcursor
33 "
34 RDEPEND="${DEPEND}
35         $(add_plasma_dep kde-cli-tools)
36         !kde-plasma/kde-gtk-config:4
37 "
38
39 src_configure() {
40         local mycmakeargs=(
41                 -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
42         )
43
44         kde5_src_configure
45 }
46
47 pkg_postinst() {
48         kde5_pkg_postinst
49         elog "If you notice missing icons in your GTK applications, you may have to install"
50         elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
51         elog "for example."
52 }