kde-plasma: Add KDE Plasma 5.16.5
[gentoo.git] / kde-plasma / kactivitymanagerd / kactivitymanagerd-5.16.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit kde5
7
8 DESCRIPTION="System service to manage user's activities, track the usage patterns etc."
9 LICENSE="|| ( GPL-2 GPL-3 )"
10 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
11 IUSE=""
12
13 RDEPEND="
14         $(add_frameworks_dep kconfig)
15         $(add_frameworks_dep kcoreaddons)
16         $(add_frameworks_dep kcrash)
17         $(add_frameworks_dep kdbusaddons)
18         $(add_frameworks_dep kglobalaccel)
19         $(add_frameworks_dep ki18n)
20         $(add_frameworks_dep kio)
21         $(add_frameworks_dep kservice)
22         $(add_frameworks_dep kwindowsystem)
23         $(add_frameworks_dep kxmlgui)
24         $(add_qt_dep qtdbus)
25         $(add_qt_dep qtgui)
26         $(add_qt_dep qtsql 'sqlite')
27         $(add_qt_dep qtwidgets)
28 "
29 DEPEND="${RDEPEND}
30         dev-libs/boost
31 "