dev-python/csv23: keyworded 0.3.2 for ia64, bug #719700
[gentoo.git] / kde-misc / kio-locate / kio-locate-0.5.3-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ECM_HANDBOOK="forceoptional" # not optional until !kdelibs4support
7 inherit ecm
8
9 DESCRIPTION="Locate KIO slave"
10 HOMEPAGE="https://www.linux-apps.com/content/show.php/kio-locate?content=120965"
11 SRC_URI="https://dl.opendesktop.org/api/files/download/id/1460972255/120965-${P}.tar.gz"
12 # See also: https://github.com/reporter123/kio-locate/commits/master
13
14 LICENSE="GPL-2"
15 SLOT="5"
16 KEYWORDS="~amd64 ~arm64 ~x86"
17 IUSE="debug"
18
19 PATCHES=(
20         "${FILESDIR}/${P}-gcc-4.7.patch"
21         "${FILESDIR}/${P}-kf5port.patch"
22 )
23
24 DEPEND="
25         dev-qt/qtgui:5
26         dev-qt/qtwidgets:5
27         kde-frameworks/kcompletion:5
28         kde-frameworks/kconfig:5
29         kde-frameworks/kconfigwidgets:5
30         kde-frameworks/kcoreaddons:5
31         kde-frameworks/kdelibs4support:5
32         kde-frameworks/ki18n:5
33         kde-frameworks/kiconthemes:5
34         kde-frameworks/kio:5
35         kde-frameworks/kwidgetsaddons:5
36 "
37 RDEPEND="${DEPEND}
38         sys-apps/mlocate
39 "