41499bff1353215fcb1c1e1891fff1ef94416886
[gentoo.git] / kde-frameworks / sonnet / sonnet-5.70.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ECM_DESIGNERPLUGIN="true"
7 QTMIN=5.12.3
8 VIRTUALX_REQUIRED="test"
9 inherit ecm kde.org
10
11 DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
12 LICENSE="LGPL-2+ LGPL-2.1+"
13 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
14 IUSE="aspell +hunspell nls"
15
16 BDEPEND="
17         nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
18 "
19 DEPEND="
20         >=dev-qt/qtgui-${QTMIN}:5
21         >=dev-qt/qtwidgets-${QTMIN}:5
22         aspell? ( app-text/aspell )
23         hunspell? ( app-text/hunspell:= )
24 "
25 RDEPEND="${DEPEND}"
26
27 src_configure() {
28         local mycmakeargs=(
29                 $(cmake_use_find_package aspell ASPELL)
30                 $(cmake_use_find_package hunspell HUNSPELL)
31         )
32
33         ecm_src_configure
34 }
35
36 src_test() {
37         # bugs: 680032
38         local myctestargs=(
39                 -E "(sonnet-test_settings|sonnet-test_highlighter)"
40         )
41
42         ecm_src_test
43 }