kde-frameworks/qqc2-desktop-style: Add dev-qt/qtdeclarative slot op
[gentoo.git] / kde-frameworks / sonnet / sonnet-5.46.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 VIRTUALX_REQUIRED="test"
7 inherit kde5
8
9 DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
10 LICENSE="LGPL-2+ LGPL-2.1+"
11 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
12 IUSE="aspell +hunspell nls"
13
14 RDEPEND="
15         $(add_qt_dep qtgui)
16         $(add_qt_dep qtwidgets)
17         aspell? ( app-text/aspell )
18         hunspell? ( app-text/hunspell:= )
19 "
20 DEPEND="${RDEPEND}
21         nls? ( $(add_qt_dep linguist-tools) )
22 "
23
24 src_configure() {
25         local mycmakeargs=(
26                 $(cmake-utils_use_find_package aspell ASPELL)
27                 $(cmake-utils_use_find_package hunspell HUNSPELL)
28         )
29
30         kde5_src_configure
31 }