kde-frameworks: Add KDE Frameworks 5.46.0
[gentoo.git] / kde-frameworks / kwindowsystem / kwindowsystem-5.46.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 VIRTUALX_REQUIRED="test"
7 inherit kde5
8
9 DESCRIPTION="Framework providing access to properties and features of the window manager"
10 LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
11 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
12 IUSE="nls X"
13
14 RDEPEND="
15         $(add_qt_dep qtgui)
16         $(add_qt_dep qtwidgets)
17         X? (
18                 $(add_qt_dep qtx11extras)
19                 x11-libs/libX11
20                 x11-libs/libXfixes
21                 x11-libs/libxcb
22                 x11-libs/xcb-util-keysyms
23         )
24 "
25 DEPEND="${RDEPEND}
26         nls? ( $(add_qt_dep linguist-tools) )
27         X? ( x11-base/xorg-proto )
28 "
29
30 RESTRICT+=" test"
31
32 DOCS=( "docs/README.kstartupinfo" )
33
34 src_configure() {
35         local mycmakeargs=(
36                 $(cmake-utils_use_find_package X X11)
37         )
38
39         kde5_src_configure
40 }