kde-frameworks: 5.40.0 amd64 stable, bug #639542
[gentoo.git] / kde-frameworks / kwayland / kwayland-5.37.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_TEST="true"
7 inherit kde5
8
9 DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
10 HOMEPAGE="https://projects.kde.org/projects/kde/workspace/kwayland"
11
12 LICENSE="LGPL-2.1"
13 KEYWORDS="amd64 ~arm ~arm64 x86"
14 IUSE=""
15
16 DEPEND="
17         $(add_qt_dep qtconcurrent)
18         $(add_qt_dep qtgui 'egl')
19         >=dev-libs/wayland-1.7.0
20         media-libs/mesa[egl]
21 "
22 RDEPEND="${DEPEND}
23         $(add_qt_dep qtwayland 'egl(+)')
24 "
25
26 # All failing, I guess we need a virtual wayland server
27 RESTRICT+=" test"