kde-frameworks: 5.40.0 amd64 stable, bug #639542
[gentoo.git] / kde-frameworks / kpty / kpty-5.37.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="Framework for pseudo terminal devices and running child processes"
9 LICENSE="LGPL-2+"
10 KEYWORDS="amd64 ~arm ~arm64 x86"
11 IUSE=""
12
13 DEPEND="
14         $(add_frameworks_dep kcoreaddons)
15         $(add_frameworks_dep ki18n)
16         sys-libs/libutempter
17 "
18 RDEPEND="${DEPEND}"
19
20 src_configure() {
21         local mycmakeargs=(
22                 -DUTEMPTER_EXECUTABLE="${EPREFIX}/usr/sbin/utempter"
23         )
24
25         kde5_src_configure
26 }